FAQ

Which database driver versions are compatible with Data Migrator?

Compatible database drivers:

  • MSSQL: 12.6.0.jre11
  • ORACLE: 12.2.0.1
  • POSTGRESQL: 42.6.0

These are available in Data Migrator S3 bucket (s3://toolbox-data-migrator/latest/3rd-party-db-drivers.zip)

Where we need to put the driver files to configure the Data Migrator?

Follow these steps:

  1. Create a folder 'drivers' in your migration project root folder, i.e. migrationProjectPath.
  2. Create the folders (MSSQL, ORACLE, POSTGRE) in folder 'drivers'.
  3. Put in each folder the driver corresponding to each database (See driver versions).
drivers_path.PNG